小紅帽技術論壇
Show all 1 posts from this thread on one page

小紅帽技術論壇 (http://redhat.ecenter.idv.tw/bbs/index.php)
- 網頁設計討論板 (http://redhat.ecenter.idv.tw/bbs/forumdisplay.php?forumid=6)
-- 《問題》新的phpMyAdmin無法用http登入 (http://redhat.ecenter.idv.tw/bbs/showthread.php?threadid=62761)


Posted by ronlee543 on 04-13-2009 23:41:

《問題》新的phpMyAdmin無法用http登入

這幾天來查了一下,發現網路上很多人問這個問題。
如果這是月經題,而且很好解決的話……請罵小力一點。
因為……找來找去還是找不到我的答案 ……

網路上很多人說的是MySQL4.0過度到4.1時的密碼相容性問題。
或是config.inc.php裡,auth_type的設定。
關於前者,我的MySQL是剛下載、剛新裝的5.1.32,所以應該不是這個問題。
比較有可能是設定上的問題。

如果在設定檔裡選擇登入方式是config,
然後user填入root、密碼打進去,可正常登入。

如果登入方式是http就不行了。
登入方式的設定是http,user空白、密碼空白。
在瀏覽器網輸入登入網址後,會跳出一個登入視窗,輸入帳號、密碼之後,
仍然停在登入視窗。請問一下,怎麼會這樣?


報告一下我這裡的環境:

無法用http登入的主機是Windows 2003,是用VMware架起來的虛擬機器。
MySQL版本:5.1.32,
phpMyAdmin版本:3.1.3.1。
config.inc.php的設定:
<?php

$cfg['blowfish_secret'] = '';
$i = 0;
$i++;

$cfg['Servers'][$i]['auth_type'] = 'http';
$cfg['Servers'][$i]['user'] = '';
$cfg['Servers'][$i]['password'] = '';

$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
$cfg['Servers'][$i]['extension'] = 'mysql';
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';

?>

我的主系統Windows XP,同樣裝了一模一樣的套件,設定也一樣,卻是完全正常!

1.為何Windows XP可以,Windows 2003不行?
我朋友的Windows 2003也是跟我一樣的設定,是正常的。不過他的是實體電腦,不是虛擬機器。

2.那…有可能是VMware的問題嗎?用VMware架起來的虛擬機器不能用phpmyadmin?這應該不可能。

3.有可能是防火牆嗎?
用config可以登入,所以,3306port沒問題,也不是防火牆的問題。

有人願意為小弟解答一下嗎?


目前使用的時域為(台北時間),現在時間是 11:33 。
Show all 1 posts from this thread on one page

Powered by: vBulletin Version 2.2.9
Copyright © Jelsoft Enterprises Limited 2000 - 2002.
小紅帽技術論壇創立於 2000/09/15 ,使用 vBulletin 合法註冊版權