小紅帽技術論壇 在這裡你可以看到你訂閱的主題,悄悄話,編輯個人資料及環境設定 免費註冊! 行事曆 搜尋其他會員 常見問題
搜尋 小紅帽流量分析 小紅帽專用irc 聊天室 Web 版!建議安裝使用 hmirc 軟體! 回首頁 登出
小紅帽技術論壇 : Powered by vBulletin version 2.2.9 小紅帽技術論壇 > 電腦類 > Unix-like 系統討論板 > FreeBSD 系統討論板 > 《問題》SSH禁止root登入問題...
  上一篇主題   下一篇主題
作者
主題、內容    發表新的文章     回覆文章

oiolong
新進會員


註冊日期: Jan 2006
來自:
發表文章數: 2

《問題》SSH禁止root登入問題...

小弟一直想要禁止root遠端登入主機

查了許多資料之後得知

要在/etc/ssh/sshd_config

加上一行

PermitRootLogin no

但我加了之後

root還是一直可以登入...

真不知道發生什麼事了...

這個是我的

/etc/ssh/sshd_config

PermitRootLogin no
Subsystem sftp /usr/libexec/sftp-server

這個是我的 /etc/ssh/ssh_config

PermitRootLogin no

兩個都設了禁止root登入了..

但還是一直可以用root遠端用putty登入...

不知道是發生什麼問題了~

希望大家能幫幫我..

文章編號:0 | 向板主反映這篇文章 | 顯示 IP

oiolong 已離線! Old Post 01-14-2006 13:11
點選這裡查看 oiolong 的個人檔案 點選這裡寄送 Email 給 oiolong 按這裡傳送悄悄話給 oiolong 按這裡搜尋 oiolong 所發表的文章 按這裡將 oiolong 加入你的好友名單 回應這篇文章含引言 按這裡編輯或刪除文章

ericsson
初級會員


註冊日期: May 2003
來自:
發表文章數: 132

該不會是忘了重新啟動 ssh ?

文章編號:1 | 向板主反映這篇文章 | 顯示 IP

ericsson 已離線! Old Post 01-14-2006 21:41
點選這裡查看 ericsson 的個人檔案 按這裡傳送悄悄話給 ericsson 按這裡搜尋 ericsson 所發表的文章 按這裡將 ericsson 加入你的好友名單 回應這篇文章含引言 按這裡編輯或刪除文章

oiolong
新進會員


註冊日期: Jan 2006
來自:
發表文章數: 2

引言:
原作者是 ericsson

該不會是忘了重新啟動 ssh ?


我有重啟啊..

執行
/etc/rc.d/sshd restart

然後出現..

Stopping sshd.
Starting sshd.

文章編號:2 | 向板主反映這篇文章 | 顯示 IP

oiolong 已離線! Old Post 01-14-2006 21:52
點選這裡查看 oiolong 的個人檔案 點選這裡寄送 Email 給 oiolong 按這裡傳送悄悄話給 oiolong 按這裡搜尋 oiolong 所發表的文章 按這裡將 oiolong 加入你的好友名單 回應這篇文章含引言 按這裡編輯或刪除文章

dooob
新進會員


註冊日期: Feb 2006
來自:
發表文章數: 13

不是這樣

你直接在

PermitRootLogin yes 前面加個#

變成下面這樣再重新啟動就行了

#PermitRootLogin yes

文章編號:3 | 向板主反映這篇文章 | 顯示 IP

dooob 已離線! Old Post 02-22-2006 13:44
點選這裡查看 dooob 的個人檔案 點選這裡寄送 Email 給 dooob 按這裡傳送悄悄話給 dooob 按這裡搜尋 dooob 所發表的文章 按這裡將 dooob 加入你的好友名單 回應這篇文章含引言 按這裡編輯或刪除文章

Martin Lin
新進會員


註冊日期: Aug 2011
來自: 台中
發表文章數: 1

Re: 《問題》SSH禁止root登入問題...

引言:
原作者是 oiolong

小弟一直想要禁止root遠端登入主機

查了許多資料之後得知

要在/etc/ssh/sshd_config

加上一行

PermitRootLogin no

但我加了之後

root還是一直可以登入...

{ ... 省略 ... }

兩個都設了禁止root登入了..

但還是一直可以用root遠端用putty登入...

不知道是發生什麼問題了~

希望大家能幫幫我..


我印象中, putty 預設是給用 telnet 登入 <-- 強烈建議 disable telnet

假如你不想給 root 直接登入, 且 還沒 diable telnet 的話。


停用 telnet 可以這模做 ...

修改 /etc/xinetd.d/telnet
disable = yes

但是建議停用 telnet 之前,
先建個允許登入之後變換身份為 root 的別的帳號 -->> 將這別帳號加到 輪子群組(wheel)
假如你還是有必要從遠端登入使用 root 權限的話。


加入允許在登入後變換身份為 root 的名單

修改 /etc/group
加入 列為 輪子群組 (wheel) 的 username, 例如是: aMiao
wheel:x:10:root,aMiao

另外, SSH 勿用預設 port 22

更換 SSH 入口,將原本預設 22 改掉 ...

修改 /etc/ssh/sshd_config <<--
找到 #Port 22 <<-- 改成別的 port,反正不要和別的已使用中的重覆就是了 (記得去掉註解#)
此例我們就改為 Port 23845 好了 。

然後重新啟動 SSH, 讓剛才的變更生效
# /etc/init.d/sshd restart
Stopping sshd: [ OK ]
Starting sshd: [ OK ]

看看 SSH 的入口號碼是否已被變更 ...
# netstat -lnp |grep ssh
tcp 0 0 ::: 23845 :::* LISTEN 2463/sshd


假如機器就在你身邊, 假如你並不需要遠端登入 root, 那就也免輪子了 ... 停用 Telnet 就好。




---------------------------------------------------------- 簽名列 -----------

Martin Lin

文章編號:4 | 向板主反映這篇文章 | 顯示 IP

Martin Lin 已離線! Old Post 08-12-2011 10:50
點選這裡查看 Martin Lin 的個人檔案 按這裡傳送悄悄話給 Martin Lin 參觀 Martin Lin 的個人首頁! 按這裡搜尋 Martin Lin 所發表的文章 按這裡將 Martin Lin 加入你的好友名單 回應這篇文章含引言 按這裡編輯或刪除文章

目前使用的時域為(台北時間),現在時間是 21:58 。    發表新的文章     回覆文章
上一篇主題   下一篇主題
友善列印 | 把這一篇寄給好朋友! | 訂閱這個主題

跳至:
評分主題:
 

討論區權限說明:
不可以 發表新文章
不可以 回覆文章
不可以 上傳附加檔案
不可以 修改你發表的文章
HTML code 目前狀態是 關閉
vB code 目前狀態是 開啟
表情符號 目前狀態是 開啟
[IMG] code 目前狀態是 開啟



< 聯絡我們 - 小紅帽全球資訊網 >

中文化:第一版 by Eric 第二版 by Jolin 於 小紅帽全球資訊網
(版權所有,翻拷必究)
小紅帽技術論壇創立於 2000/09/15 ,使用 vBulletin 合法註冊版權